**Drawing tool gallery**

Illustrator provides the following drawing tools:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Pen tool (P)</strong></td>
<td>draws straight and curved lines to create objects</td>
</tr>
<tr>
<td><strong>Add Anchor Point tool (+)</strong></td>
<td>adds anchor points to paths</td>
</tr>
<tr>
<td><strong>Delete Anchor Point tool (-)</strong></td>
<td>deletes anchor points from paths</td>
</tr>
<tr>
<td><strong>Convert Anchor Point tool (Shift+C)</strong></td>
<td>changes smooth points to corner points and vice versa</td>
</tr>
<tr>
<td><strong>Line Segment tool ()</strong></td>
<td>draws individual straight line segments</td>
</tr>
<tr>
<td><strong>Arc tool</strong></td>
<td>draws individual concave or convex curve segments</td>
</tr>
<tr>
<td><strong>Spiral tool</strong></td>
<td>draws clockwise and counterclockwise spirals</td>
</tr>
<tr>
<td><strong>Rectangular Grid tool</strong></td>
<td>draws rectangular grids</td>
</tr>
<tr>
<td><strong>Polar Grid tool</strong></td>
<td>draws circular chart grids</td>
</tr>
<tr>
<td><strong>Rectangle tool (M)</strong></td>
<td>draws squares and rectangles</td>
</tr>
<tr>
<td><strong>Rounded Rectangle tool</strong></td>
<td>draws squares and rectangles with rounded corners</td>
</tr>
<tr>
<td><strong>Ellipse tool (L)</strong></td>
<td>draws circles and ovals</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Polygon</td>
<td>Draws regular, multi-sided shapes.</td>
</tr>
<tr>
<td>Star</td>
<td>Draws stars.</td>
</tr>
<tr>
<td>Flare</td>
<td>Creates lens-flare or solar-flare-like effects.</td>
</tr>
<tr>
<td>Pencil (N)</td>
<td>Draws and edits freehand lines.</td>
</tr>
<tr>
<td>Smooth</td>
<td>Smooths bezier paths.</td>
</tr>
<tr>
<td>Erase</td>
<td>Erases paths and anchor points from the object.</td>
</tr>
</tbody>
</table>

**See also**

[About the toolbox](#)
To draw straight lines followed by curves

1. Using the Pen tool, click corner points in two locations to create a straight segment.
2. Position the Pen tool over the selected endpoint.
   A convert anchor point icon appears next to the Pen tool when it is positioned correctly.
3. Drag to create a direction line and to set the slope of the curved segment you’ll create next. Then release the mouse button.

   ![Drawing a straight segment followed by a mixed segment (part 1)]
   
   **A.** Straight segment completed  **B.** Positioning Pen tool over endpoint  **C.** Dragging direction point

4. Reposition the Pen tool where you want the curved segment to end, drag to complete the curve, and release the mouse button.

   ![Drawing a straight segment followed by a mixed segment (part 2)]
   
   **D.** Repositioning the Pen tool  **E.** Dragging direction point  **F.** New curve segment completed
To draw curves followed by straight lines

1. Using the Pen tool, drag to create the first smooth point of the curved segment, and release the mouse button.
2. Reposition the Pen tool where you want the curved segment to end, drag to complete the curve, and release the mouse button.

Drawing a curved segment followed by a straight segment (part 1)
A. First smooth point of curved segment completed and Pen tool positioned over endpoint  B. Dragging to complete the curve

3. Position the Pen tool over the selected endpoint. A convert anchor point icon appears next to the Pen tool when it is positioned correctly. Click the anchor point to convert the smooth point to a corner point.
4. Reposition the Pen tool where you want the straight segment to end and click to complete the straight segment.

Drawing a curved segment followed by a straight segment (part 2)
C. Positioning Pen tool over existing endpoint  D. Clicking endpoint  E. Clicking next corner point
To convert between smooth points and corner points

1. Select the entire path you want to modify.
2. Select the Convert Anchor Point tool.
3. Position the Convert Anchor Point tool over the anchor point you want to convert, and do one of the following:
   - To convert a corner point to a smooth point, drag a direction point out of the corner point.
     - Dragging a direction point out of a corner point to create a smooth point
   - To convert a smooth point to a corner point without direction lines, click the smooth point.
     - Clicking a smooth point to create a corner point
   - To convert a corner point without direction lines to a corner point with independent direction lines, first drag a direction point out of a corner point (making it a smooth point with direction lines). Release the mouse button only (don't release any keys you may have pressed to activate the Convert Anchor Point tool), and then drag either direction point.
   - To convert a smooth point to a corner point with independent direction lines, drag either direction point.
     - Converting a smooth point to a corner point

See also
- About paths
- Drawing tool gallery
- Direction lines and direction points
To join two endpoints

1. Select the endpoints.
   If the endpoints are coincident (on top of each other), drag a marquee through or around both endpoints to select them.

2. Choose Object > Path > Join.

3. If the endpoints are coincident, a dialog box appears to let you specify the type of join you want. Select the Corner option (the default) or the Smooth option, and click OK.

Joining endpoints
A. Selecting and joining coincident endpoints  B. Selecting and joining noncoincident endpoints

See also
To select anchor points
To simplify paths

Simplifying a path removes extra anchor points without changing the shape of the path. Removing unnecessary anchor points simplifies your artwork, reducing the file size, and making it display and print faster.

1. Select the object.
2. Choose Object > Path > Simplify.
3. Set the Curve Precision to control how closely the simplified path follows the original path.
   
   Select Preview to show a preview of the simplified path and list the number of points in the original and simplified paths.
4. Select additional options, and click OK.
Simplify options

**Curve Precision** Enter a value between 0% and 100% to set how closely the simplified path should follow the original path. A higher percentage creates more points and a closer fit. Any existing anchor points are ignored except for endpoints of a curve and corner points (unless you enter a value for Angle Threshold).

**Angle Threshold** Enter a value between 0 and 180° to control the smoothness of corners. If the angle of a corner point is less than the angle threshold, the corner point is not changed. This option helps keep corners sharp, even if the value for Curve Precision is low.

**Straight Lines** Creates straight lines between the object’s original anchor points. Corner points are removed if they have an angle greater than the value set in Angle Threshold.

**Show Original** Shows the original path behind the simplified path.
Reshaping tool gallery

Illustrator provides the following tools for reshaping objects:

- **The Rotate tool** (R) rotates objects around a fixed point.
- **The Reflect tool** (O) flips objects over a fixed axis.
- **The Scale tool** (S) resizes objects around a fixed point.
- **The Shear tool** skews objects around a fixed point.
- **The Reshape tool** adjusts selected anchor points while keeping the overall detail of the path intact.
- **The Free Transform tool** (E) scales, rotates, or skews a selection.
- **The Blend tool** (W) creates a series of objects blended between the color and shape of multiple objects.
- **The Warp tool** (Shift+R) molds objects with the movement of the cursor (like molding clay, for example).
- **The Twirl tool** creates swirling distortions within an object.
- **The Pucker tool** deflates an object by moving control points towards the cursor.
- **The Bloat tool** inflates an object by moving control points away from the cursor.
The Scallop tool adds random curved details to the outline of an object.

The Crystallize tool adds random spiked details to the outline of an object.

The Wrinkle tool adds wrinkle-like details to the outline of an object.

See also

About the toolbox
Liquify tool options

Double-click a liquify tool to set tool options.

**Width and Height** Controls the size of the tool cursor.

**Angle** Controls the orientation of the tool cursor.

**Intensity** Specifies the rate of change for the distortion. Higher values equal faster changes.

**Use Pressure Pen** Uses the input from a tablet or pen instead of the Intensity value. If you don’t have a pressure-sensitive tablet attached, this option is dimmed.

**Complexity (Scallop, Crystallize, and Wrinkle tools)** Specifies how closely the results of the particular brush are spaced on the object’s outline. This is closely tied with the Detail value.

**Detail** Specifies the spacing between points introduced into the object’s outline (higher values space points closer together).

**Simplify (Warp, Twirl, Pucker, and Bloat tools)** Specifies how much you want to reduce the superfluous points that do not measurably affect the overall appearance of the shape.

**Twirl Rate (Twirl tool only)** Specifies the rate at which the twirl is applied. Enter a value between –180° and 180°. Negative values twirl the object clockwise and positive values twirl counterclockwise. The object twirls faster with values that are closer to either –180° or 180°. To twirl slowly, specify a rate close to 0°.

**Horizontal and Vertical (Wrinkle tool only)** Specifies how far apart the control points are placed.

**Brush Affects Anchor Points, Brush Affects In Tangent Handles, or Brush Affects Out Tangent Handles (Scallop, Crystallize, Wrinkle tools)** Enables the tool brush to make changes to these properties.
Keys for editing shapes

This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch Pen tool to Convert Anchor Point tool</td>
<td>Alt</td>
<td>Option</td>
</tr>
<tr>
<td>Switch between Add Anchor Point tool and Delete Anchor Point tool</td>
<td>Alt</td>
<td>Option</td>
</tr>
<tr>
<td>Switch Scissors tool to Add Anchor Point tool</td>
<td>Alt</td>
<td>Option</td>
</tr>
<tr>
<td>Switch Pencil tool to Smooth tool</td>
<td>Alt</td>
<td>Option</td>
</tr>
<tr>
<td>Move current anchor point while drawing with Pen tool</td>
<td>Spacebar-drag</td>
<td>Spacebar-drag</td>
</tr>
<tr>
<td>Cut a straight line with Knife tool</td>
<td>Alt-drag</td>
<td>Option-drag</td>
</tr>
<tr>
<td>Cut at 45° or 90° with Knife tool</td>
<td>Shift + Alt-drag</td>
<td>Shift + Option-drag</td>
</tr>
<tr>
<td>Turn shape mode buttons in Pathfinder palette into Pathfinder commands</td>
<td>Alt + Shape mode</td>
<td>Option + Shape mode</td>
</tr>
</tbody>
</table>
## Selection tool gallery

Illustrator provides the following selection tools:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Selection tool" /></td>
<td>The Selection tool (V) selects entire objects.</td>
</tr>
<tr>
<td><img src="image" alt="Direct Selection tool" /></td>
<td>The Direct Selection tool (A) selects points or path segments within objects.</td>
</tr>
<tr>
<td><img src="image" alt="Group Selection tool" /></td>
<td>The Group Selection tool selects objects and groups within groups.</td>
</tr>
<tr>
<td><img src="image" alt="Lasso tool" /></td>
<td>The Magic Wand tool (Y) selects objects with similar attributes.</td>
</tr>
<tr>
<td><img src="image" alt="Lasso tool" /></td>
<td>The Lasso tool (Q) selects points or path segments within objects.</td>
</tr>
</tbody>
</table>

**See also**

- [About the toolbox](link)
- [Keys for selecting](link)
About clipping masks

A **clipping mask** is an object whose shape masks other artwork so that only areas that lie within the shape are visible—in effect, clipping the artwork to the shape of the mask. The clipping mask and the objects that are masked are called a **clipping set** and are marked with a dotted line in the Layers palette. You can make a clipping set from a selection of two or more objects or from all objects in a group or layer.

![Before masking (left) compared to after masking (right)](image)

The following guidelines apply to creating clipping masks:

- The objects that you mask are moved into the clipping mask’s group in the Layers palette if they don’t already reside there.
- Only vector objects can be clipping masks; however, any artwork can be masked.
- If you use a layer or group to create a clipping mask, the first object in the layer or group masks everything that is a subset of the layer or group.
- Regardless of its previous attributes, a clipping mask changes to an object with no fill or stroke.

💡 To create a semitransparent mask, use the Transparency palette to create an opacity mask.

See also

- Cutting, dividing, and trimming objects
- To create opacity masks
To create a clipping mask for a group or layer

1. Create the object you want to use as the mask. This object is called the **clipping path**. Only vector objects can be clipping paths.

2. Move the clipping path and the objects you want to mask into a layer or group.

3. In the Layers palette, make sure that the masking object is at the top of the group or layer, and then click the name of the layer or group.

4. Click the Make/Release Clipping Masks button at the bottom of the Layers palette or select Make Clipping Mask from the Layers palette menu.

**See also**

- About the Layers palette
- About the stacking order
Discover the power of compound shapes

Using compound shapes is one of the easiest ways to create illustrations in Adobe Illustrator. You start by drawing basic shapes and then use the Pathfinder palette to combine them in different ways. In this tutorial, you’ll learn how to add and subtract shapes, as well as how to use the Layers palette.

1. Draw a series of overlapping ellipses.

First, click the Default Fill And Stroke button in the toolbox. This sets the fill to white and the stroke to black. Then select the Ellipse tool, and drag to draw a series of overlapping ellipses.

To move an ellipse, select it with the Selection tool and drag it to a different location. When you’re satisfied with the placement of all the shapes, drag around all the ellipses to select them.

2. Add the ellipses together.

If the Pathfinder palette isn’t showing, choose Window > Pathfinder. Then click the Add To Shape Area button in the Pathfinder palette.

You just created a compound shape (a shape that consists of two or more objects). You can verify this by looking in the Layers palette. If the Layers palette isn’t showing, choose Window > Layers. Then click the triangle to the left of Layer 1 to see the listing for the compound shape.
3. Subtract a rectangle.

Select the Rectangle tool and draw a rectangle that overlaps the bottom of the compound shape. When you're finished drawing, use the Selection tool to select all the shapes. Then click the Subtract From Shape Area button in the Pathfinder palette.

It may be difficult to tell what changed while all the shapes are selected, so click anywhere on the artboard to deselect them. Now you can see that the rectangle has been subtracted from the ellipses. If you look in the Layers palette, you’ll see that Illustrator created a new compound shape containing the rectangle and the first compound shape.

4. Rename the compound shape in the Layers palette.

Double-click the words “Compound Shape” in the Layers palette. Enter a more meaningful name for the shape, and click OK. We named our shape “Cloud.”

The Layers palette is very useful for keeping track of the objects in a document. In addition, you can use it to select objects by clicking in the selection column between the circle and the scroll bar. (See About the Layers palette.)
5. Draw three nested circles.

You'll use the circles to create a sun, so draw them in proportion to the cloud. Start by selecting the Ellipse tool, and Shift+dragging to draw the outer circle. Then position the pointer over the center of the circle, and Shift+Alt+drag (Windows) or Shift+Option+drag (Mac OS) to draw the middle circle. (Holding down the Alt or Option key lets you draw the circle from the center outward.) Repeat again to draw the inner circle.

We named the circles "Outer Circle," "Middle Circle," and "Inner Circle" in the Layers palette.

6. Create the sun's rays.

Select the outer circle and choose Effect > Distort & Transform > Zig Zag. Select Preview, and adjust the values for Size and Ridges Per Segment. When you're satisfied with the results, click OK.

7. Make the sun a compound shape.

Select the outer circle, then hold down Shift and select the middle circle. (Holding down Shift lets you select multiple objects.) Click the Subtract From Shape Area button in the Pathfinder palette to combine the two shapes. Hold down Shift, select the inner circle, and click the Add To Shape Area button in the Pathfinder palette.

We named the compound shape "Sun" in the Layers palette.

8. Move the sun behind the cloud.

Select the sun, and choose Object > Arrange > Send Backward. Then use the Selection tool to drag the sun behind the cloud.
Notice how the sun is now listed below the cloud in the Layers palette. This is because the Layers palette reflects the stacking order of your artwork. You can change the stacking order by dragging objects up or down in the Layers palette. (See About the stacking order.)
Summary of Pathfinder effects

Add  Traces the outline of all objects as if they were a single, merged object. The resulting shape takes on the paint attributes of the top object.

Intersect  Traces the outline of the region overlapped by all the objects.

Exclude  Traces all nonoverlapping areas of the objects, and makes overlapping areas transparent. Where an even number of objects overlap, the overlap becomes transparent. Where an odd number of objects overlap, the overlap becomes filled.

Subtract  Subtracts the frontmost objects from the backmost object. You can use this command to delete areas of an illustration by adjusting the stacking order.

Minus Back  Subtracts the objects in back from the frontmost object. You can use this command to delete areas of an illustration by adjusting the stacking order.

Divide  Separates a piece of artwork into its component filled faces (a face is an area undivided by a line segment).

Note:  When you use the Divide button in the Pathfinder palette, you can use the Direct Selection or Group Selection tool to manipulate the resulting faces independently of each other. You can also choose to delete or preserve unfilled objects when applying the Divide command.

Trim  Removes the part of a filled object that is hidden. It removes any strokes and does not merge objects of the same color.

Merge  Removes the part of a filled object that is hidden. It removes any strokes and merges any adjoining or overlapping objects filled with the same color.

Crop  Divides artwork into its component filled faces, and then deletes all the parts of the artwork that fall outside the boundary of the topmost object. It also removes any strokes.

Outline  Divides an object into its component line segments, or edges. This command is useful for preparing artwork that needs a trap for overprinting objects.

Note:  When you use the Outline button in the Pathfinder palette, you can use the Direct Selection or Group Selection tool to manipulate each edge independently. You can also choose to delete or preserve unfilled objects when applying the Outline command.

See also
Pathfinder options
To mix colors using the Hard Mix or Soft Mix effect
To create a trap
Expanding objects

Expanding objects enables you to divide a single object into multiple objects that make up its appearance. For example, if you expand a simple object, such as a circle with a solid-color fill and a stroke, the fill and the stroke each become a discrete object. If you expand more complex artwork, such as an object with a pattern fill, the pattern is divided into all of the distinct paths that created it.

You typically expand an object when you want to modify the appearance attributes and other properties of specific elements within it. In addition, expanding objects may be helpful when you want to use an object that is native to Illustrator (such as a mesh object) in a different application that doesn’t recognize the object.

Before (left) and after (right) expanding an object that has a fill and stroke

Expanding is particularly helpful if you are having difficulty printing transparency effects, 3D objects, patterns, gradients, strokes, blends, flares, envelopes, or symbols.
To create a compound shape

Creating a compound shape is a two-part process. First, you establish a compound shape in which all components have the same shape mode. Then, you assign shape modes to the components until you obtain the desired combination of shape areas.

1. Select all the objects you want to be part of the compound shape.
   You can include paths, compound paths, groups, other compound shapes, blends, text, envelopes, and warps in a compound shape. Any open paths you select are automatically closed.

2. Do one of the following:
   - In the Pathfinder palette, click a Shape Modes button. Each component of the compound shape is assigned the shape mode you select.
   - Select Make Compound Shape from the Pathfinder palette menu. Each component of the compound shape is assigned the Add mode by default.

3. Change the shape mode of any component by selecting it with the Direct Selection tool or Layers palette and clicking a Shape Mode button.
   Note that you never need to change the mode of the backmost component, because its mode is not relevant to the compound shape.

   **To sustain maximum performance, create complex compound shapes by nesting other compound shapes (containing up to about 10 components each) instead of using many individual components.**

See also

About the Pathfinder palette
## Keys for selecting tools

This is not a complete list of keyboard shortcuts. This table lists only those shortcuts that are not displayed in menu commands or tool tips.

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection tool</td>
<td>V</td>
<td>V</td>
</tr>
<tr>
<td>Direct Selection tool</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Magic Wand tool</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Lasso tool</td>
<td>Q</td>
<td>Q</td>
</tr>
<tr>
<td>Pen tool</td>
<td>P</td>
<td>P</td>
</tr>
<tr>
<td>Add Anchor Point tool</td>
<td>+ (plus)</td>
<td>+ (plus)</td>
</tr>
<tr>
<td>Delete Anchor Point tool</td>
<td>- (minus)</td>
<td>- (minus)</td>
</tr>
<tr>
<td>Convert Anchor Point tool</td>
<td>Shift + C</td>
<td>Shift + C</td>
</tr>
<tr>
<td>Type tool</td>
<td>T</td>
<td>T</td>
</tr>
<tr>
<td>Line Segment tool</td>
<td>\ (backslash)</td>
<td>\ (backslash)</td>
</tr>
<tr>
<td>Rectangle tool</td>
<td>M</td>
<td>M</td>
</tr>
<tr>
<td>Ellipse tool</td>
<td>L</td>
<td>L</td>
</tr>
<tr>
<td>Paintbrush tool</td>
<td>B</td>
<td>B</td>
</tr>
<tr>
<td>Pencil tool</td>
<td>N</td>
<td>N</td>
</tr>
<tr>
<td>Rotate tool</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Reflect tool</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>Scale tool</td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td>Warp tool</td>
<td>Shift + R</td>
<td>Shift + R</td>
</tr>
<tr>
<td>Free Transform tool</td>
<td>E</td>
<td>E</td>
</tr>
<tr>
<td>Symbol Sprayer tool</td>
<td>Shift + S</td>
<td>Shift + S</td>
</tr>
<tr>
<td>Column Graph tool</td>
<td>J</td>
<td>J</td>
</tr>
<tr>
<td>Mesh tool</td>
<td>U</td>
<td>U</td>
</tr>
<tr>
<td>Gradient tool</td>
<td>G</td>
<td>G</td>
</tr>
<tr>
<td>Tool</td>
<td>Key</td>
<td>Key</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------</td>
<td>-----</td>
</tr>
<tr>
<td>Eyedropper tool</td>
<td>I</td>
<td>I</td>
</tr>
<tr>
<td>Live Paint Bucket tool</td>
<td>K</td>
<td>K</td>
</tr>
<tr>
<td>Live Paint Selection tool</td>
<td>Shift + L</td>
<td>Shift + L</td>
</tr>
<tr>
<td>Blend tool</td>
<td>W</td>
<td>W</td>
</tr>
<tr>
<td>Slice tool</td>
<td>Shift + K</td>
<td>Shift + K</td>
</tr>
<tr>
<td>Scissors tool</td>
<td>C</td>
<td>C</td>
</tr>
<tr>
<td>Hand tool</td>
<td>H</td>
<td>H</td>
</tr>
<tr>
<td>Zoom tool</td>
<td>Z</td>
<td>Z</td>
</tr>
</tbody>
</table>